QuickScript

Scripts et tutoriels concernant les scripts
Règles du forum
Techniques pour gagner du temps ou automatiser des tâches
Répondre
Avatar du membre
spitfrog
entraideur amiral
entraideur amiral
Messages : 3193
Enregistré le : 06 juil. 2015, 13:35
Sexe : Homme
Localisation : Normandie
Système d'exploitation : Windows 10
Système d'exploitation 64 bits : Oui
Version de PaintShop Pro : X9 64 bits
Contact :

QuickScript

Message par spitfrog »

Je ne sais pas pourquoi, mais lorsque je rejoue un quickscript, il bloque toujours au moment où j'ai déplacé un calque.

Code : Tout sélectionner

    # LayerArrange
    App.Do( Environment, 'LayerArrange', {
            'Path': (0,1,[],False), 
            'MoveAboveSibling': True, 
            'Path': None, 
            'GeneralSettings': {
                'ExecutionMode': App.Constants.ExecutionMode.Silent, 
                'AutoActionMode': App.Constants.AutoActionMode.Default, 
                'Version': ((23,0,0),1)
                }
            })
Est-ce que quelqu'un a eu le même problème ?
Avatar du membre
Cassel
entraideur expérimenté
entraideur expérimenté
Messages : 435
Enregistré le : 29 août 2015, 06:34
Sexe : Femme
Système d'exploitation : Windows Seven
Système d'exploitation 64 bits : Oui
Version de PaintShop Pro : 9
Contact :

Re: QuickScript

Message par Cassel »

Je sais que c'est vieux de quelques mois, mais voici une suite.

Est-ce que tu as un message d'erreur quand tu exécute ceci? Cette commande s'exécute dans des conditions spécifiques. Par exemple, si tu n'as pas deux calques, ou si le calque actif n'est pas au même endroit, etc.

Les commandes et les scripts sont "stupides" parce qu'ils ne voient pas le contexte, donc ne peuvent pas s'ajuster comme on le feraiten voyant le travail.
Avatar du membre
spitfrog
entraideur amiral
entraideur amiral
Messages : 3193
Enregistré le : 06 juil. 2015, 13:35
Sexe : Homme
Localisation : Normandie
Système d'exploitation : Windows 10
Système d'exploitation 64 bits : Oui
Version de PaintShop Pro : X9 64 bits
Contact :

Re: QuickScript

Message par spitfrog »

Quelques mois plus tard...
Merci pour ta réponse Carole, tu as certainement raison quand tu dis que les scripts n'aiment pas les déplacements de calques, c'est probablement la cause de l'erreur.
Répondre