Page 1 sur 2

Ajouter des infos

Posté : 25 sept. 2018, 18:51
par Zen-Luck
Cette fonction permet d'ajouter un texte sur une image ou des infos EXIF.
Cela peut être utile dans certains cas.
On y accède par Fichier / Ajouter des infos

Je rencontre un problème avec les fichiers de mon vieux Nikon D80.
Certaines infos EXIF ne s'affichent pas (Ouverture et Vitesse d'obturation) :
2019 D80 ajouter infos.jpg
2019 D80 ajouter infos.jpg (27.35 Kio) Vu 2983 fois
Sur le site de Dpreview, j'ai téléchargé une image prise avec le même Nikon D80, et là, les infos qui ne s'affichent pas sur mon image s'affichent correctement :
D80 dpreview.jpg
D80 dpreview.jpg (39.67 Kio) Vu 2983 fois
Pourquoi cette différence de comportement ?

Avez-vous déjà essayé cette fonction sur vos images et voyez-vous parfois des infos qui ne s'affichent pas ?

Re: Ajouter des infos

Posté : 26 sept. 2018, 08:11
par spitfrog
Je ne sais pas, mais le D80 (sortie 2006) est antérieur à la sortie des spécifications Exif 2.3 (2010) c'est peut être la raison :menfin: il y a peut-être eu aussi des modèles de D80 sortis après 2010 ce qui expliquerait pourquoi celui de Dpreview affiche les infos, ou alors encore, ils ont mis à jour le firmware de leur appareil, ou encore, c'est une escroquerie, ils ont changé les infos Exif... :mrgreen: ou c'est tout simplement tes photos qui subissent l'inexorable passage du temps, elles s'effritent, se font vieilles, perdent des informations, c'est la vie, ou la mort... :trash:

Re: Ajouter des infos

Posté : 26 sept. 2018, 22:16
par Zen-Luck
spitfrog a écrit : 26 sept. 2018, 08:11 c'est tout simplement tes photos qui subissent l'inexorable passage du temps, elles s'effritent, se font vieilles, perdent des informations, c'est la vie, ou la mort...
Je pense plutôt que c'est PaintShop Pro qui perd des infos. Je sais qu'il perd certaines infos EXIF lors d'enregistrement dans un autre format, mais je ne me souviens plus du cas précis.

Il serait intéressant de vérifier la fonctionnalité décrite de PaintShop Pro avec des photos un peu plus anciennes qui contenaient des infos EXIF.

Re: Ajouter des infos

Posté : 27 sept. 2018, 17:16
par Zen-Luck
spitfrog a écrit : 26 sept. 2018, 08:11 Je ne sais pas, mais le D80 (sortie 2006) est antérieur à la sortie des spécifications Exif 2.3 (2010) c'est peut être la raison :menfin: il y a peut-être eu aussi des modèles de D80 sortis après 2010 ce qui expliquerait pourquoi celui de Dpreview affiche les infos
Tu es perspicace ... Bravo ! :super: Il y a bien eu un D80 "retouché" sorti après le mien... :menfin:
Je viens de tester avec une photo prise par un D100, antérieur à mon D80, et PaintShop Pro n'affiche pas tous les champs de l'Exif non plus. :0:
J'ai remonté le bug chez Corel... :marteau:

Re: Ajouter des infos

Posté : 28 sept. 2018, 01:06
par Coeur
Zen-Luck a écrit : 27 sept. 2018, 17:16J'ai remonté le bug chez Corel... :marteau:
Oh c'est bien Zen-Luck, tu auras un bon point pour cette assiduité beta-testeuse sans faille :super:

Re: Ajouter des infos

Posté : 28 sept. 2018, 10:37
par Zen-Luck
Coeur a écrit : 28 sept. 2018, 01:06 Oh c'est bien Zen-Luck, tu auras un bon point pour cette assiduité beta-testeuse sans faille :super:
Je ne sais pas où j'ai mis mon carnet de bons points ... :lol:

Ce bug pourrait être gênant pour les utilisateurs qui ont des photos prises avec un appareil avant 2010 qui semble être l'année pivot jusqu'à preuve du contraire.
Si un utilisateur de ce forum possède d'anciens JPG, ce serait bien de pouvoir tester la fonction pour vérifier si les infos EXIF prévues pour l'affichage par PaintShop Pro sont bien lues par lui.

Re: Ajouter des infos

Posté : 28 sept. 2018, 19:39
par Zen-Luck
Zen-Luck a écrit : 27 sept. 2018, 17:16 Il y a bien eu un D80 "retouché" sorti après le mien... :menfin:
Ben non, je me suis emmêlé les pinceaux... Il n'y a pas eu de D80 différent. J'ai confondu. La chose qui aurait pu changer, c'est le firmware...

J'ai continué mes tests mais cela ne donne aucune indication sur la raison du non affichage.
Image d'un Nikon D100 (site de Dpreview) : PaintShop Pro n'affiche pas toutes les infos EXIF. Version EXIF : 2,20. Photo prise en 2002.
Image d'un Olympus FE100 X710 (en prêt) : PaintShop Pro n'affiche pas toutes les infos EXIF. Version EXIF : 2,21. Photo prise en 2005.
Image d'un Fuji FinePix S602 (que j'avais) : PaintShop Pro affiche toutes les infos. Version EXIF : 2,20. Photo prise en 2008.
Image de Nikon D80 (Dpreview) : PaintShop Pro affiche les infos. Version EXIF : 2,21. Photo prise en 2006.
Image de mon D80 : PaintShop Pro n'affiche pas toutes les infos. Version EXIF : 2,21. Photo prise en 2008.

Corel devra se débrouiller avec ça ... :-?

Re: Ajouter des infos

Posté : 01 oct. 2018, 11:26
par spitfrog
Oui, c'est curieux tout de même :grat:
- n' y a-t-il pas un réglage dans ton D80 qui modifierait la façon dont les informations sont enregistrées ?
- est-ce que tu as mis à jour le firmware de ton appareil (ce qui pourrait expliquer pourquoi l'autre D80 affiche les exifs et pas le tien)
- as-tu essayé de lire les exifs avec un autre programme ?

Re: Ajouter des infos

Posté : 01 oct. 2018, 11:46
par spitfrog
Du coup, je sais que ce n'est pas ta question initiale, mais plutôt que d'altérer les photos en y insérant des informations Exifs, tu peux créer automatiquement un fichier texte qui porte le même nom que la photo (avec l'extension .txt). Si la procédure t’intéresse...

Tu obtiendras ceci, un fichier texte par photo contenant les informations Exifs de la photo.
exiftool.gif

Re: Ajouter des infos

Posté : 01 oct. 2018, 21:36
par Zen-Luck
spitfrog a écrit : 01 oct. 2018, 11:26 Oui, c'est curieux tout de même :grat:
- n' y a-t-il pas un réglage dans ton D80 qui modifierait la façon dont les informations sont enregistrées ?
- est-ce que tu as mis à jour le firmware de ton appareil (ce qui pourrait expliquer pourquoi l'autre D80 affiche les exifs et pas le tien)
- as-tu essayé de lire les exifs avec un autre programme ?
Il est possible que mon D80 enregistre différemment ces infos mais elles s'y trouvent et sont quand même lues par mon Lightroom 6 par exemple.
C'est PaintShop Pro qui ne les lit pas correctement dans ce cas-là (Ajouter des infos) car affichées avec Gestion de photo, je vois ces données EXIF.
Les tests effectués avec les autres fichiers (ceux d'autres appareils) montrent que PaintShop Pro en lit certains et pas d'autres, selon l'appareil qui les a pris. La curiosité, dans le cas présent, c'est qu'un même modèle d'appareil peut produire des images qui sont lues différemment par PaintShop Pro. Je pense à un problème de conformité du modèles d'appareil pour le marché européen. L'appareil est légèrement différent pour le marché américain, bien qu'il porte le même nom. Le cas le plus "exemplaire" c'est Canon qui change le nom de l'appareil selon le marché où il est distribué. Le EOS Rebel T7 vendu aux USA est renommé EOS 2000D en Europe. Le changement peut affecter aussi le firmware, je pense.
C'est une "anomalie" de PaintShop Pro.

Le problème a été soumis à Corel...

PS : mon D80, curieusement, n'affiche pas son firmware selon la procédure indiquée par Nikon. Je n'y ai pas accès pour le changer. Mais dans les infos EXIF, sa version est affichée : 1.11 qui est la dernière version pour ce modèle. Le firmware du D80 de Dpreview est 1.00 !